заметки об администрировании и программировании (python, ruby, php). Траблшутинг в «примерах» и HOWTO.

😎 О себе | 📚 Литература и ресурсы | ⚡ Все посты | 📮 E-mail

Проблема установки Zabbix-server/Zabbix-proxy Ubuntu 18.04


root@zabbix:~# apt install zabbix-server-mysql zabbix-frontend-php zabbix-agent 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zabbix-frontend-php : Depends: ttf-dejavu-core but it is not installable or
                                ttf-japanese-gothic but it is not installable
                       Depends: php-mbstring but it is not installable
                       Depends: php-bcmath but it is not installable
 zabbix-server-mysql : Depends: libiksemel3 (>= 1.2) but it is not installable
                       Depends: libssh2-1 (>= 1.0) but it is not installable
                       Depends: fping but it is not installable
                       Recommends: virtual-mysql-server
E: Unable to correct problems, you have held broken packages.


Решение:

vim /etc/apt/sources.list


###### Ubuntu Main Repos
deb http://us.archive.ubuntu.com/ubuntu/ bionic main universe
deb-src http://us.archive.ubuntu.com/ubuntu/ bionic main universe

###### Ubuntu Update Repos
deb http://us.archive.ubuntu.com/ubuntu/ bionic-security main universe
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates main universe
deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-security main universe
deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-updates main universe 


Источник

Поделиться
Отправить
 163   11 мес   Ubuntu 18.04   Zabbix
Популярное